Eroare de compilare în Android Studio Atunci când un simplu Hărți Google Android proiect API v2

voturi
6

Recent am migrat la noua Android Studio IDE bazat pe IntelliJ

Ghidurile am urmat au fost:

  1. https://developers.google.com/maps/documentation/android/start ( pentru elementele de bază )

  2. Cum pot crea o aplicație Android în Android Studio care utilizează v2 Google Maps Api? ( Pentru importul necesare serviciile Google Play și bibliotecile de suport în studio Android )

Toate bibliotecile au fost detectate în mod corespunzător de către Android Studio și eu nu am primit nici o „bibliotecă de erori nu a fost găsită“. Proiectul a fost prezentat fără erori. Apoi, când am încercat să-l compilați am primit această eroare.

Gradle: 
FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':AID-AmritaInfoDesk:compileDebug'.
> Compilation failed; see the compiler error output for details.

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.


Could not execute build using Gradle distribution 'http://services.gradle.org/distributions/gradle-1.6-bin.zip'.

Acesta a fost meu explorer.java fișier

package com.aid.explorer;

import com.google.android.gms.maps.GoogleMap;
import com.google.android.gms.maps.SupportMapFragment;
import com.google.android.gms.maps.model.LatLng;
import com.google.android.gms.maps.model.MarkerOptions;

import android.os.Bundle;
import android.support.v4.app.FragmentActivity;


public class explorer extends FragmentActivity {

    private GoogleMap mMap;

    @Override
    protected void onCreate(Bundle savedInstanceState) {
        super.onCreate(savedInstanceState);
        setContentView(R.layout.explorer);
        setUpMapIfNeeded();
    }

    @Override
    protected void onResume() {
        super.onResume();
        setUpMapIfNeeded();
    }


    private void setUpMapIfNeeded() {
        // Do a null check to confirm that we have not already instantiated the map.
        if (mMap == null) {
            // Try to obtain the map from the SupportMapFragment.
            mMap = ((SupportMapFragment) getSupportFragmentManager().findFragmentById(R.id.map))
                    .getMap();
            // Check if we were successful in obtaining the map.
            if (mMap != null) {
                setUpMap();
            }
        }
    }


    private void setUpMap() {
        mMap.addMarker(new MarkerOptions().position(new LatLng(0, 0)).title(Marker));
    }
}

Și acest lucru mi -a fost explorer.xml fișier

<?xml version=1.0 encoding=utf-8?>
<fragment xmlns:android=http://schemas.android.com/apk/res/android
          android:id=@+id/map
          android:layout_width=match_parent
          android:layout_height=match_parent
          class=com.google.android.gms.maps.SupportMapFragment/>

Aș dori să știu ce a mers prost. orice ajutor ar fi foarte apreciat

Întrebat 19/05/2013 la 10:47
sursa de către utilizator
În alte limbi...                            


2 răspunsuri

voturi
0

Mai întâi trebuie să dea mai multe informații despre eroare. În loc de a folosi compilatorul extern trebuie să încercați să utilizați compilator intern (schimbarea setărilor compilator)

Publicat 19/05/2013 la 14:30
sursa de către utilizator

voturi
3

Am fost, urmând aceleași instrucțiuni, cu excepția am fost crearea unui nou proiect. În conformitate cu structura proiectului am scos fateta Android-Gradle și a fost capabil de a construi cu succes. Opțional, se poate actualiza gradle construi fișiere și adăugați fateta Android-Gradle la bibliotecă servicii de joc.

NOTA: Am schimbat numele de director Google Play Services.

build.gradle pentru Google Play Servicii de bibliotecă.

apply plugin: 'android-library'

buildscript {
    repositories {
        mavenCentral()
    }

    dependencies {
        classpath 'com.android.tools.build:gradle:0.4'
    }
}

dependencies {
    compile files('libs/android-support-v4.jar')
    compile files('google-play-services.jar')
}

android {
    compileSdkVersion 17
    buildToolsVersion '17.0.0'

    sourceSets {
        main {
            manifest.srcFile 'AndroidManifest.xml'
            java.srcDirs = ['src']
            resources.srcDirs = ['src']
            aild.srcDirs = ['src']
            renderscript.srcDirs = ['src']
            res.srcDirs = ['res']
            assets.srcDirs = ['assets']
        }
    }
}

build.gradle pentru aplicația de testare.

buildscript {
    repositories {
        maven { url 'http://repo1.maven.org/maven2' }
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:0.4'
    }
}
apply plugin: 'android'

dependencies {
    compile files('libs/android-support-v4.jar')
    compile project(':lib-google-play-services')
    compile files('../lib-google-play-services/libs/google-play-services.jar')
}

android {
    compileSdkVersion 17
    buildToolsVersion "17.0.0"

    defaultConfig {
        minSdkVersion 11
        targetSdkVersion 16
    }
}
Publicat 21/05/2013 la 12:55
sursa de către utilizator

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more